Home CAR & BIKES Replaced the starter relay on my Kawasaki Ninja 300 at the 9000km...

Replaced the starter relay on my Kawasaki Ninja 300 at the 9000km mark

Replaced the starter relay on my Kawasaki Ninja 300 at the 9000km mark
Replaced the starter relay on my Kawasaki Ninja 300 at the 9000km mark

Since last monsoon, I faced some trouble with the starter. The bike would randomly not start, only a clicking sound.

BHPian audioholic recently shared this with other enthusiasts.

Inching towards six years and just 9000kms:

Not many updates on this thread since the Ninja is like a Garage queen. I put 9k kms in each of my car every year, and the Ninja only crossed it after six years owing to sparing use, typically once a week office commute when the weather permits and hardly any highway riding. Everytime I wash the bike, it still shines as good as new, with no wear and tear or any fading shown on the parts. I have been maintaining it on my own, following all replacement intervals as specified by the manufacturer and with genuine part replacements only.

Since last monsoon, I faced some trouble with the starter. The bike would randomly not start and there would just be a clicking sound heard with no action from the starter. Initially I attributed the issue to the battery being weak due to age and non usage and contemplated replacing it. But the issue was very random and when it didnt occur the cranking was normal. Hence I removed and cleaned the connector to the starter motor, which had a very wierd rubber boot pointing upwards which will make water seep into the boot and nullify the whole purpose of having the boot. This had led to the starter motor wire lug to corrode and completely rusted the nut. Cleaned it up and thought the problem was gone but it reappeared after a while.

Next step in the order of expenses was to replace the battery and I ended up buying a normal Exide battery in replacement to the Yuasa battery at 2k rupees and while the first crank was quick and I assumed the problem was solved, it reappeared in a few days. This issue was making me leave the engine running in all signals and temporary stops. Finally did some google and figured out there is a starter relay that goes kaput in the bike. Since I would hear the clicking noise every time, I always thought that the relay was working fine and there was some other problem. Now this was supposed to be close to 11k in the ASC. Talk about the stupid costs of these parts.

Ordered this along with a few other rubber parts and fasteners from Megazip, which turned out to be an excellent place for OEM parts and came at a landing cost of 8k for the genuine relay. Note that there were some alternates available for 2k odd rupees in Amazon but I did not want to get an aftermarket replacement for such a part.

Replacement was fairly straight forward, even though it involves removal of the seat cowling, seat assembly, disconnecting the ignition controller, removing battery. Since I removed all these I ended up cleaning the whole place and then removed the old relay. Turns out that the old relay had corroded badly inside and its contacts and traces were in bad shape. Even the allen bolts were badly corroded. Cleaned up the whole mess and refitted the new relay with plenty of silicone grease and a generous coat of anti rust spray around the area.

The Michellin Pilot street radial at front has developed multiple cracks and was not holding pressure off late. Hence I plan to replace the tyre in a few days. Have Apollo H1 and Vredestein as two options. H1s are relatively cheap and available in 110/70 for front whereas Vredestein is only available in 120/70 and thats more than double expensive. As for the rear, I had upsized to 150/60 in the beginning however only the H1 is available in the size while the Vredestein is available in 150/70. Thinking of Vredestein at the rear and Apollo at front for now.

Check out BHPian comments for more insights and information.

Source link